attack of the POODLE SSL3 exploit

This just in from GeoTrust: GeoTrust is aware of and currently investigatingCVE-2014-3566┬áSSL v3.0 POODLE vulnerability. This vulnerability affects servers still running SSL 3.0. It centers on cipher block chaining (CBC) …